Wednesday, February 29, 2012

Onda Vi40 Elite Firmware Update 4.0.3_v 0.8

A few days ago, Onda released a 4.0.3._v0.8 firmware update, yesterday they finally also released it for MY hardware version (the v1).

You can download the firware either from their site or here:

Vi40_V1_v0.8
Vi40_V3_v0.8

The good news is, the calendar sync with a google account is working now and the Android Market is also included.

The bad news is, the Android Market isn't finding all the apps that it's supoosed to. Essentials like google maps, street view, youtube, etc., they are all missing :-(


I thought, o.k., why not use the modified build.prob from my previous market fix, in that build.prob I used a fingerprint from a Samsung Galaxy S2 phone to fix the market issues. I gave it a shot - NO SUCCESS :-(


Right now, I am clueless what the problem is and how to fix it. I always thought that the build.prob is the answer to all the market problems one might have, I guess I was wrong.


So, if anyone has a good idea how we can fix this issue, please comment.

Thanks :-)
UPDATE: If you update the Market to "Google Play" the missing apps will appear!!! :-)

56 comments:

  1. I flashed the new firmware and then the new market script from http://www.slatedroid.com/topic/29969-market-script-onda-vi40/

    It works like a charm and all normal google apps and others get installed perfectly. In the script zip it's included some apps that need to be installed manually... I have now working google voice and wifi location service :D

    ReplyDelete
    Replies
    1. Thanks for the info, I'll give it a try :-)

      But will it fix the apps missing from the Market problem? That is my main concern about 0.8 firmware :-(

      Delete
    2. I think YouTube was already not Market available in 0.6, I think I copied the .apk
      Some people on the French forum are saying the when you reinstall Flash after 0.8 upgrade it works. I am catious but I'll try.

      Delete
    3. Hi Francis :-) I'm not concerned about having to install Youtube, google map, street view etc. manually, my concern is, if THOSE are missing on the market, what else is missing? Probably a whole lot! :-( Also, if those apps don't show up on the market, there is no way they can ever be updated automatically :-(

      Delete
    4. I flashed the new firmware and it works fine except for the bugs and apps that do not show up. The biggest issue i have found was no support for videos. Netflix for example has audio and no video. I have tried almost every video player with no success. AEmails were fixed with Opera. As for the apps like Maps i loaded on the sd card of another unit the installed it without any issues on the Vi40. Any ideas with the Netflix videod?

      Delete
  2. Whitin Build.prop:

    For Samsung 4.0.3 market maybe this:

    ro.build.description=GT-I9100-user 2.3.4 GINGERBREAD XXKG2 release-keys
    ro.build.fingerprint=samsung/GT-I9100/GT-I9100:2.3.4/GINGERBREAD/XXKG2:user/release-keys

    must be?

    ro.build.description=GT-I9100-user 4.0.3 IML74K XXLPB release-keys
    ro.build.fingerprint=samsung/GT-I9100/GT-I9100:4.0.3/IML74K/XXLPB:user/release-keys

    ReplyDelete
  3. Hi..

    It's possible install that market fix on ONDA Vi10 tablet? ICS 4.0.3

    Greetings..

    ReplyDelete
    Replies
    1. Hi :-)
      I don't know, I haven't tested it.

      Delete
  4. @ Stefano:

    I have no idea why your posts won't show up, I get the by e-mail but they don't show up here :-(

    ReplyDelete
  5. I applied the market fix and everything seemt to work just fine.
    I could download apps and push them from https://market.android.com/ to my Onda. Apps like Maps, Facebook, Streetview, ninesky and off course Drawsomething :-)

    BTW: Chrome beta & Flash are still not working.

    ReplyDelete
    Replies
    1. Try Flash in Opera Mobile.
      I have been watching a TV channel on my vi40 last night in Flash/Opera, could not do that in 0.6 (tested).

      Delete
  6. THE real good news about 0.8 is that Flashplayer works in Opera Mobile!

    ReplyDelete
  7. And you can watch YouTube movies in desktop mode (i.e. you don't need the YouTube app neither do you need the YouTube mobile).

    Colonel...is that not GREAT?

    ReplyDelete
    Replies
    1. That sounds great :-) I haven't tested it yet, are you using the latest Opera and flash versions for this?

      I'm a little busy right now, I have two tables to review ;-)

      Delete
    2. Yes. I reloaded Flash after the upgrade.

      Delete
    3. What flash player are you using? I flashed the update and when i play Netflix i get sound no video. This happens with most other videos as well. By running the market fix does that fix the market in the new v.08 update?
      Thanks

      Delete
  8. Finally, the applications that are 'missing' were already not available in 0.6, I don't think this is a 0.8 consequence.

    ReplyDelete
    Replies
    1. I'm not so sure about that?!? If I remember right, google maps was available in the 0.6 version? But I could be wrong.

      Delete
  9. Colonel,

    Have a look at this
    http://tabletrepublic.com/forum/cortex-a8-allwinner-a10/allwinner-a10-general-faq-non-tablet-specific-556.html

    paragraph §4

    I agree Google Maps disapeared, but the other app were already not available in 0.6.

    ReplyDelete
  10. Hi Colonel,
    Just to share or maybe you already realised that the lock button on the side of vi40 is to lock the screen to prevent screen rotation .

    ReplyDelete
  11. How can i install the new firmware step by step?? Greetings

    ReplyDelete
  12. Guys,

    Did the new firmware improve the performance and lagging of the tablet? Besides the Market and application related stuff, what else did you notice in the new FW?

    ReplyDelete
    Replies
    1. Flashplayer now working in Opera mobile.

      Delete
  13. Hello ColonelZap,

    first thanks for the MarketPatch for the FW V06 - great job! Even with my Galaxy Tab I have the Problems that are certain apps not available within the Market. Some of the apps in the Market for Onda Vi40 are not offered such as YouTube, I transferred from my Galaxy Tab! I think, several Apps are not supported by ICS

    Now my current problem:

    After I have installed the V08 firmware on my Onda Vi40, I get the battery indicator no longer under control. Within 5 minutes > 10% of the battery capacity is used up. At 89% it seems that the consumption would be normal. When plugging and unplugging the charger, there are abrupt changes in the battery indicator.

    I've tested this behavior with a virgin device and with all my apps installed. No difference ..

    I've also tried out some calibration for the battery tips from various forums without success.

    Is this a general problem of Onda Vi40 or are there tips for me what am I doing wrong?

    Thank you for the support!

    ReplyDelete
    Replies
    1. Hi :-)
      I'm sorry, I haven't used my Vi40 in a while, so I haven't noticed a behavior like that?!?

      Of course it could be a problem with the firmware, but it could also be a hardware issue. Unfortunately I don't know how to delete the battery status.

      What you could try is "bumb charging" check this out (for example)

      http://www.androidcentral.com/bump-charging-what-it-and-how-do-it

      Delete
    2. Hi!

      Does anyone noticed some kind of vertical lines on the screen after few minutes of standby mode. Those lines aren´t much visible, so you must watch very carefully to see them. It looks like the resolution decreases and the image became less sharp.

      This behavior dissapeared after 10 mins of use.

      But, if you use the tablet by switching on and off each time you use it, the screen works properly.

      Coud you please tell me if this issue is a hardware problem or can be solved by firmware?

      Thanks to all.
      Marcelo

      Delete
    3. Yes i have same problem in stanby mode after ten minutes i see white stripes on the screen.
      and also i have one dead pixel on the screen.
      i am thinking to send back tablet where i bought

      Delete
    4. I have the same screen problem with just one difference. Mine is full of vertical, one digonal line and one horizontal that are visible ALL THE TIME. You can see photos here http://www.androidtablets.net/forum/onda-tablet-forum/38930-i-received-my-vi40-androidinabox-com-lot-problems.html#post208738

      Delete
  14. After the update to 0.8 (from 0.6 with fullmarket and clock to 1200) i've found that the wifi does not work properly...(authentication problems ???)
    Does anyone experienced the same?

    Thanks,
    Emanuele.

    ReplyDelete
  15. Something got updated automatically on mine last night from v0.8 to v0.8+ and now have access to apps that didn't show up with the v0.8 originally installed. The market got updated to go play as well. Before if i search for the missing apps manually in a browser and tried to install it said not compatible with device. Seems okay now.

    an aside the camera on the back is not very good unless theres a lot of light.

    ReplyDelete
  16. Hi all,

    I received one of these about a week ago and I know that it is firmware version 0.6 on Android 4.0.3.
    Ok so I have to upgrade it's firmware and of course I can see the link but how exactly do I do this. Also how do I know which revision version I have v1 or v3 so that I can click the right link.

    Thanks in advance for any help.

    ReplyDelete
  17. Hey Colonel

    how do you update the market to google play?

    Thank you

    ReplyDelete
    Replies
    1. Go to the settings - applications, finde the market there and clear the cache. The next time you start the market, it should be updated.

      Delete
    2. nope still doesn't work. Do you have any other suggestions? By the way do you have any idea if/when there will be an update so the cpu is finally 1.5 ghz?

      Delete
    3. you can install this : http://www.mediafire.com/?gcq6h9y7ht8q6kk

      Delete
  18. Install new update then update market to google play then download the Vi40 market fix to get all the apps.

    ReplyDelete
  19. Hey,
    got it fixed now with the market script from slatedroid. But now when i use my tab i get sometimes (fairly often) a red border arround the screen. how can i get rid of it?

    ReplyDelete
  20. Wow. Just wow. It took me about half an hour of varied-speed button pushing, but full success. I think in my case I was better off holding down both the Menu and Power buttons until my Acer Win7 laptop beeped to indicate successful USB driver action. The upgrade is definitely got a better UI than the original, and no problems accessing GooglePlay (but refused to let me D/L HboGo, the rats!). ColonelZap: I'm incredibly greatful for your posts. If you're ever near Boston MA I would be happy to treat you to dinner.
    Carl

    ReplyDelete
    Replies
    1. Congratulations!!! And wow, thanks for the invite, if I'm ever there, I might take you up on that offer :-)

      Delete
  21. firmware onda vi40 4.0.3 v1.0
    -very good
    -adobe flash 11 on web.ok
    link download: http://115.com/file/ansc7nhd#

    ReplyDelete
    Replies
    1. Thank you so much :-)

      Is there a V1 version available as well? Thanks :-)

      Delete
  22. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. Thank you so much :-) Let's hope Onda will also release this version for the V1 hardware (which I have).

      Delete
    2. This comment has been removed by the author.

      Delete
    3. or link http://www.onda.cn/Mp3/ProductInfo.aspx?ProductId=179
      google translate

      Delete
  23. hi im a newbie, could someone please point me to right direction on how i could flash the new firmware for onda vi10.

    thanks.

    ReplyDelete
  24. onda vi40 firmware 4.0.3 v1.0 for vi40 v1
    http://www.onda.cn/Mp3/ProductInfo.aspx?ProductId=179
    13/3/2012

    ReplyDelete
    Replies
    1. Thanks, I already uploaded it :-)

      http://colonelzap.blogspot.com/2012/03/onda-vi40-elite-firmware-update-403v-10.html

      Delete
  25. Sorry Colonel, I'm not real sure to understand since i did not succes with my Vi30W and ICS v.08. I have updated the market to google play and cleaned the cache but google maps, google earth, youtube... and a lot more are always missing.

    Did you used the Lordbsn script or just the modified build.prop to fix the market before update it to Google Play to have those applications on the market?

    Btw, I must say a big thanks for all those precious info and tests you do.

    ReplyDelete
    Replies
    1. I have the same issue....

      Delete
  26. Could someone please confirm if Wifi location works with FW4.0.3 v1.0 on Google maps? Thanks in advance

    ReplyDelete
  27. DO NOT BUY ANYTHING FROM FASTCARDTECH!!!!!!!!!!!!!
    I have bought from them an Onda Vi40 plus an M99 cell phone. Order Nr. is US2012031906193
    I learned in this blog about these products and about FastcardTech.
    I made my order 17 days ago and paid them by Western Union 15 days ago. Both products were in stock and I have checked it BEFORE I made the order and they confirmed it by message.
    They say in their site that if you pay with Western Union the shipping will be in the next 24 hs.
    They have aknowledge the order, the stock, send me a shipping tracking number and indicated in their site as shipped. All this 2 days after I putted the order.
    Two days ago they send me an email saying that shipping did not happended inspite it was indicated as shipped in their site because Vi40 they have is 16Gb and not 8 Gb as they aknowledge in stock prior my order. They requested USD 20 more and I did pay that also 2 days ago. I used PayPal.
    Now I can not get any response from these people.
    Ah, amount of order is USD 353,39
    AT THIS POINT I THINK THEY HAVE STOLEN MY MONEY !!
    Ernesto Araoz

    ReplyDelete
  28. Hi there,

    Got my VI40 and here are my first impressions.
    First I want to say that it is a really nice pad and it works really smooth and looks great. Batterytime is fine, screen is excellent =)
    But, the built in browser... It loads only half pages, is slow, it hangs, takes all cpu. No its the worst ever, really. Installed Opera from google play and it works perfect. Only drawback is that youtube is not working in opera, as far as I tried yet.

    So first impression is great but the browser must be working better.

    ReplyDelete
  29. I'm pretty new to this. Could one of you experts help me figure out the basics?

    1. I have a Onda Vi40 with Android 4.03. It was advertised as having 8 GB. But when I go to the

    Settings -> Storage

    tab, it shows up as only having 5.55 GB Total (internal storage).

    Is there something I do not understand, or did they lie?

    BTW, I updated everything it wanted me too that wasn't Chinese - didn't fix the problem.

    2. I had some trouble detecting our wireless N network. In particular, I had to set the router back from 5 GHz to 2.4 GHz. Does that seem right? If it helps any, the tablet says somewhere that it is using "Baseband 1". I don't know what that means.

    3. Because I don't know Chinese, and all instructions are in Chinese, I went to their website, using a PC. First off, Avast Antivirus detector said there was a Virus on the page, and didn't want me to connect. I reluctantly connected anyway, by reverting to a back-up that used an earlier version of Avast.

    Onda's page says there is no English language documentation. OMG.

    So is there an English language instruction manual for something similar, with something close to Android 4.03?

    4. I bet if someone translated the manual (for real, not the complete mess a computer translation always produces), lots of us would happily pay $1 for it, maybe more.

    5. Is there a good free antivirus program?

    6. At this point I am having so much trouble without directions that it takes me a minute or two of hitting random buttons to get to the list of aps. It stays in locked mode until I hit enough buttons for an array of dots to appear at the top right, which I push. Does anyone have a morereliable way to get to the aps?

    Thanks.

    ReplyDelete
  30. I have the vi40 ultimate which has the android stuff in Chinese, although I have modified the default and language settings to English.
    Is there an easy way to change this or is there a firmware which is recomended. Also the ultimate has only one soft key, what is the correct key sequence to trigger the firmware upload (using livesuit).

    ReplyDelete
  31. I've a problem with my tablet Onda Vi20 , my little brother touch my pattern lock , when i saw that , too many pattern lock . but i never add my google account on that .... so how can i unlock that pattern ... and let me know how to enter recovery on that tablet ... Thanks

    ReplyDelete