Saturday, March 10, 2012

Onda Vi40 Elite Firmware Update 4.0.3_v 1.0

Onda just released a 4.0.3 v 1.0 firmware, right now only available for the V3 hardware versions.

For a (hopefully) faster download click here.

UPDATE:
Here's the firmware for the V1 hardware: CLICK

I can't test it, my device has the V1 hardware, please feel free to post your experiences with this firmware.

Thanks :-)

Google Translate:

A new FLASH web video player can be directly through the Google default browser Pro browser to watch the potatoes, Sohu and other online video websites.
2, new support for portable hotspot functionality, and your flat panel into a wireless hot spot. Mobile phones, computers and other devices to share Internet access through the tablet.
3, the new WIFI DIRECT function, from the router in the network environment, multi-Direct. Multiplayer games such as "city car" through WIFI DIRECT function is carried out.
4, to load more applications, integrated flat-panel user guide novice users more easily
5, performance improvement, security Bunny ran points over 2900 points, a 16 percent increase from the before version of the 2500 points race points, performance
6, part of amendments to previous versions of BUG, enhance software compatibility, the system is running more stable

114 comments:

  1. I have the V3 and have the v.08 installed and was thinking of flashing the v1.0 above. one question I have is after flashing will I have to reinstall all of the apps I have installed now? If so I am running Titanium Backup and I believe that there is a way to install backed up apps all at once, or for it to do them automatically, is this the case?

    ReplyDelete
  2. Hi :-)

    If you flash a new firmware, everything you have installed will be deleted. I think titanium backup will work to backup apps and to restore them but I've never done that before.

    ReplyDelete
    Replies
    1. I flashed my unit and prior to the flash I backed all of my apps using Titanium Backup. After the flash I changed the language back to English, reset the unit settings, then reinstalled the apps from my sd card where they were backed up. This worked flawlessly and pretty simple. The biggest difference I have found so far is the support for Flash11 which now allows me the ability to watch movies on Netflix. The only negative so far is that I find it a little sluggish. Will update after I play with it for a while. Starting to get iPad quality at half the price.

      Delete
  3. Hi,
    I flashed this new version with the LiveSuit included and for some reason all the applications I installed and the setting for English were always lost after a power down. Made a Reset to cache and nothing changed. Every time I powered down was like a factory reset and came back in Chinese with no new applications installed (only the firmware original ones).

    Re flashed with the old LiveSuit and the problem is resolved now.

    Regards.

    ReplyDelete
    Replies
    1. Thank you so much for the info, good to know :-)

      Delete
    2. Hello,

      Where can I find the old LiveSuit?

      Also, I downloaded the V3 version as per top of this page. I am completely lost by the instructions prompted in the LiveSuit interface. It states the likes of a "PVP" button to press, then any buttons + power button 10 times, and whilst doing this, finding another hand to plug the USB cable I presume.

      I also tried the other method as per the other page with James' instructions and downloaded all the files linked there. My PC would not even find the drivers.

      Whereas with this version here on this page, I got as far as my PC launching the driver install and finding them. I run Windows 7 64 bits.

      I am very close to pull the whole of my hair off my head :D

      Please help :)

      Delete
    3. I suggest to use this Livesuit version:

      http://colonelzap.blogspot.de/2012/01/allwinner-a10-livesuit-flashing.html

      Start Livesuit, select the image you want to flash. Press and hold the Menu button, plug in the cable, press the power button several times and hope that it will trigger Livesuit to start the flashing process.

      Good luck :-)

      Delete
  4. Hi, My name is Juan, I flashed the 4.0.3 v10 and the flash player is pre installed, and is working.

    ReplyDelete
    Replies
    1. Juan, no puedo actualizarla, ya tengo el archivo pero no se si tengo que ponerla en un modo de actualizacion.

      Delete
  5. Besides the new changes, I can just applaude Onda for releasing new firmwares so fast! I'm glad I bought it! I'm just hating a bit the lag it has in some pages, some menus, and the animation when I open the app drawer. Besides that, I just had some incompatibility with some games, but I guess it's for the "still-to-be-polished" ICS on the Onda.

    ReplyDelete
  6. Flash, Skype, Crome working, graphic glitches many apps worked fine on 0.8 now not.. (Box, Opera, Switch Pro ecc) will test further and retry flashing.

    ReplyDelete
    Replies
    1. Thanks for the feedback :-)
      I hope Onda will also release a V1 version, I really want to test this firmware as well.

      Delete
    2. Never mind it was a bad flash, apps now seams working will update later

      Delete
  7. Before update when i make a video conversation with gtalk my video had seen like green filter video but now everything is perfect.
    But i still have a stuck problem when i try to download from market? Anyone can help me about stucking problem. i cant download anything stuck at the dowloading... screen. i am using new version google play store

    ReplyDelete
    Replies
    1. Have you tried to clear the market cache? Sometimes that helps.

      Delete
    2. yes colonel i try a lot of different process but :/.

      Delete
    3. Hello Anonymous, just want to know if you were able to fix the market? I have the same problem as well and I have not been able to handle this for weeks now.

      Delete
  8. Hi guys,
    My feedback for the new firmware.

    So far so good!
    A lot faster. SCB Shell now is"usable".
    I have my Onda over clocked to 1.2 and is stable. Antutu benchmark is over 3300.
    Flash videos work excellent even in HD.
    WI-FI feels better.
    I'm really satisfied. Only BT Support its still missing...

    Would Luke to say something to Onda directly but don't know an email address...

    Regards.

    ReplyDelete
  9. I noticed just about every app I bought show up without needing to do the market fix off of slate droid.
    Would you still recommend using that one from last month(for youtube GTA ect)?
    I though it wasn't extremely polished (Still an excellent job!), meaning the facelock apk not installing but included and the updated browser needing to be installed manually.
    Just wanted to ask since you seem to be an authority on this tablet.
    Great work!

    ReplyDelete
  10. Hello Colonel.
    Onda published the new v1.0 firmware version to the V1 model of vi40.
    You can check it now with your own device.

    Regards ;)

    ReplyDelete
    Replies
    1. Hey, thanks for the info :-) I'll start downloading it now :-)

      Delete
  11. After Flashing to v1.0 on V1 WiFi seems to bug out for me.. :(
    he's been "turning Wi-Fi on..." for an hour now.
    Anyone had this problem or found a fix yet?

    ReplyDelete
    Replies
    1. I don't have this problem but sometimes it helps to cut off the power from you router for a few minutes. I sometimes have this problem with other devices.

      Delete
    2. Hello Colonel!
      I'm curious - any insights?

      Regards ;)

      Delete
    3. Haven't done much, looks like the user interface is faster / smoother, Market is there, calender syc works and the stock browser supports flash. That's my first impression :-)

      Delete
    4. I've flashed it again and all seems to be fixed now.
      Thanks again for your blog btw, this has been really helpfull.

      Cheers

      Delete
  12. hello can you show how to update the tablet i try with their instractiun but didnt succed please help me, thenx in advace

    ReplyDelete
    Replies
    1. That's the best I can give you:

      http://colonelzap.blogspot.com/2012/01/onda-vi40-firmware-flashing-guide-by.html

      Delete
    2. Hi Colonel,

      Need to rewrite this procedure as it is simpler now.

      Regards,
      Francis

      Delete
  13. thenx know the tablet is stuck when i restart the tablat i try to press on the reset button but that doesnt work what can i do?

    ReplyDelete
    Replies
    1. If you have a version 1 onda vi40, then you must download V1.
      If you have version 3 onda vi40, then you must download V3. I think this causes your issue ;)

      Delete
    2. its stuck on the start.befor the home page

      Delete
  14. Dear ColonelZap,

    with Hard key of volume can we go for ClockworkMod Recovery or hard key is compulsory,

    please advise.

    iam interested in the Vistrue V3 tablet but it doesn't the hard key (Volume)
    http://www.visture.com/vone.asp



    Arifullah

    ReplyDelete
  15. small correction no hard key (Volume)

    Dear ColonelZap,

    without Hard key of volume can we go for ClockworkMod Recovery or hard key is compulsory,

    please advise.

    iam interested in the Vistrue V3 tablet but it doesn't the hard key (Volume)
    http://www.visture.com/vone.asp



    Arifullah

    ReplyDelete
    Replies
    1. Well, the Vi40 doesn't have any volume buttons, so even if you can get into a recovery mode, you can't navigate through it.

      Delete
    2. Dear ColonelZap,

      is your Cube 9UGT2 had stereo loud speaker (Not ears phone)

      as iam interested to buy http://www.visture.com/vone.asp

      Thanks
      Arifullah

      Delete
  16. Hi,
    You can get to recovery mode and the hard buttons work as the volume buttons in other tablets.
    I did it when trying to flash 0.6. Just don't remember if you have to press menu or setting button...

    Regards

    ReplyDelete
  17. Hello,

    I just received my Onda Vi40 today, running ICS 4.0.1.

    I just can't get Windows7 Professional to recognize it. I tried 64Bit and 32Bit.

    Even if I choose the usbdrv File manually from the Livesuit Folder I just get "This device cannot start. (Code10)" from the Device Manager as an answer.

    In USB Storage Mode the Device shows just fine, but if I enable USB-Debugging I can't get it to work.

    Has anyone using Windows7 experienced this issue? I don't know what to do!

    ReplyDelete
  18. Hello,

    I have upgraded to the 1.0 firmware for my v1 version and the market still does not have apps like youtube or flickr.
    Do I need to install the market fix.

    Thanks for your grat job.

    ReplyDelete
    Replies
    1. Hi :-)
      I noticed the missing apps as well, I really don't know if the market fix will resolve this problem but I doubt it. I haven't figured out what causes the apps to be missing :-(

      Delete
    2. Hi, I´ve tried and still not finding the apps.
      I have installed the AppBrain App Market in the tablet and I can find apps like Youtube but It doesnt allow you to download it telling you that your device is not compatible

      Delete
    3. Try this:
      http://www.slatedroid.com/topic/30620-fixed-google-play-issues-missing-apps/

      Works on firmware v1.0 as well. Do not use Marketfix, Google Play gets buggy.

      All apps just working fine.

      (battery seems to be using more power with firmware v1.0)

      Delete
    4. I tried that, still couldn't find google maps, street view etc. in the Market :-(

      Delete
    5. I found both google maps and street view via alternate download sites; and they seem to work fine once installed.

      Delete
  19. I had the same problem trying to install Google Chrome also Go Lau ncher+ for ICS is not stable. For some reason this tablet is not recognized as a 4.0. I just hope that Onda keeps upgrading its firmware. The potential of this tablet is unlimited.

    ReplyDelete
  20. Hi.

    I have bourght 2 onda V10 tablet on for my son and one for me.. I have installed google play on my sons and it works fine. but on mine it crashes every time I try to start it up any one know what to do?

    ReplyDelete
  21. Dear ColonelZap,

    is your Cube 9UGT2 had stereo loud speaker (Not ears phone)

    as iam interested to buy http://www.visture.com/vone.asp

    Thanks
    Arifullah

    ReplyDelete
  22. I'm trying to update, but it keeps on 0%.

    I turn my tablet (VI40) off en on with middle button pushed in, but it will not update or go to update mode.

    help?

    ReplyDelete
    Replies
    1. Found this blog:
      http://colonelzap.blogspot.com/2012/01/onda-vi40-firmware-flashing-guide-by.html

      which helped me a lot, thank you!

      Delete
  23. I have purchased an onda vi40 and it arrived 3 days ago... worked fine but 3 days later the screen is locked and isnt responsive to the touch not allowing me to slide and unlock it... everything else looks fine.. any ideas

    ReplyDelete
  24. did you try to reset it using small pin in reset hole ?

    ReplyDelete
  25. Does anyone having problem with Launcher that the autorotate stoped working? I have check all the correct settings, and it should allow it to be on. However when I use 1 of the autorotate utilities on market, it is like as something has turn off autorotate straigh away.

    It seems just the Launcher, autorotate works in most apps, like google earth.

    ReplyDelete
    Replies
    1. Maybe you have the screen orientation switch on the side of the tablet on?

      Delete
    2. Damn, you are right, I always wonder what that button is for. I know I should RTFM before I use it, but hey who does anyway, cheers :D

      Delete
    3. NOBODY RTFM, at least I don't, LOL :-D

      Delete
  26. Did anyone try connecting this tablet to TV via HDMI?

    ReplyDelete
    Replies
    1. Sure, it works like a charm :-)

      Delete
    2. Its not working for me, not sure what the problem is :-|

      Delete
    3. @ColonelZap did you try with the new firmware?

      Delete
    4. Yes, I did, I just tested it again, HDMI works great for me.

      Delete
    5. @ColonelZap I replaced the cable with a new one and now it works like a charm :-)

      Delete
    6. That's great news! Enjoy your HDMI :-)

      Delete
    7. hi, i have an onda vi10 elite and usb otg function is not working, and also hdmi isn`t working either, i've tried with the v1.0 and with the 0.8....do you know how to fix it? Thanks

      Delete
    8. hi! first of all many thanks to colonelzap and francis who helped me through the update of my onda vi40elite!!! onda advised me to install this because I had some issues with my battery...don't know yet if it made a difference...
      anyway, even before the update my hdmi connection stopped working. it used to work fine in the beginning with a standard cable with mini adapter. suddenly it started breaking up - i thought maybe the adapter was a bit dodgy and bought a new mini hdmi cable. tried both hdmi channels on my tv, but am getting "no signal" on both. the update has made no difference. does anybody know what to do? my main reason for buying the tablet was the hdmi slot to watch bbc iplayer and netflix etc...:-(

      Delete
  27. Hey Colonezap,
    You doing a great job here. Thanks a lot.

    I have two Onda Vi40, one I bought some time in February. The second just arrived with a CD in it. Can I use the CD to upgrade to 4.0.3 v 1.0 firmware?

    Please can you tell me how I can identify if my is v1 or v3?

    Lex

    ReplyDelete
  28. Hi there Colonelzap,
    First let me thank you for all the great work you are doing. Ordered a couple of these vi40's for the school I work in but I'm after running into a serious problem!!! I spent an evening the other day setting one of them up and shut it down after my efforts. But the next morning I turned it on, it seems like it has reset itself back to chinese, and all my apps and user data was gone. So I reinstalled the new 1.0 v3 firmware with livesuit, just upgraded it rather than formatting it, and when I turned it on everything was back as it was!! But again after I turn it off for a couple of hours it does it again!! Reading your different posts someone else had this problem in the past. Any idea whats happening with it?
    Oh and tried it with a 2nd tablet just in case but same thing happened!!
    Conor

    ReplyDelete
    Replies
    1. Hi Conor,

      It happened to me as well. (Read my previous post above).
      The problem is the LiveSuit that comes with firmware v.1.
      You need to use the previous LiveSuite and you'll fix it.

      Regards.

      Delete
    2. Hi Juan,
      Thanks a million for your help. Will give that a go now and will get back to you with any developments.

      Thanks again

      Delete
  29. Hi everyone,
    I just succeeded in updating my firmware. Thank you everyone esp Colonelzap.

    I got the Wifi Direct and saw some improvements but I had an issue with the update. My Baseband version is still 0.6 I was thinking it would be updated to 1.0? Please help my curiousity.

    Thank you all!

    ReplyDelete
  30. Hello, Colonel. I wonder, how you've managed to overclock your device up to 1200MHz and be able to run Quadrant normally. May be V1 is a better choice than V3 :)
    I can set harmlessly only 1152MHz. 1200Mhz is available (no restart and hanging), but it is useless after that. No test runs to the end, no game starts. May be the trouble is in the firmware 1.0?

    ReplyDelete
    Replies
    1. Could be the firmware, I don't know?!? I don't overclock it anymore anyways, I don't get the feeling overclocking really makes much of a difference in performance.

      Delete
  31. Hi all,
    i just received a vi40 and was wondering what the latest firmware is for this unit and how to determine which version it is running?
    Also, there are allot of chinese apps. Is it OK to delete them or are any of them required for the system to run properly?

    Tia!

    ReplyDelete
  32. Latest firmware is v1. Flashing to this will automatically delete some of the software on the unit but it is worth it as it runs alot smoother after.

    ReplyDelete
  33. Hi guys,
    i'm not sure if I'm running the latest version.
    Here are my specs:

    android version 4.0.3
    baseband version 1.0
    kernel version 3.0.8+
    build number mid-eng 4.0.3 iml74k 20120308 test-keys

    Please advise!

    ReplyDelete
  34. Hi folks,

    I am so new to this, it ain't stupid. Please bear with me, please.

    Can I flash this firmware using my Macbook?

    thanks

    ReplyDelete
    Replies
    1. Hi, @Helluva. I've been looking around, and so far as I can tell there's no direct way to do so. Booting into Windows via BootCamp might work. I've tried using VirtualBox but no luck; looks like the virtual Windows environment doesn't "see" the USB port well enough for LiveSuite to fire up. What we need is a real Android adb expert who could figure out how to open the .img file and push the system upgrade into the Vi40's directory structure.

      Delete
  35. Meh :( I am having problems with voice search and all other related apps that require voice search :( Any idea folks? :)

    ReplyDelete
  36. latest firmware Android4.0.3-1.1 is out
    http://www.onda.cn/MP3/productinfo.aspx?productid=179

    ReplyDelete
  37. Hey Colonel Zap,

    So I downloaded the firmware up date and have Livesuit installed, but the directions are in Chinese and I don't really understand what I'm supposed to do. It says something about holding down an M key and then pressing the power button a few times, but I guess it needs to be in some sort of order or something? Anyhow, any help would be greatly appreciated regarding this. Thanks!

    ReplyDelete
    Replies
    1. Hi :-)

      Did you read this?

      http://colonelzap.blogspot.de/2012/01/onda-vi40-firmware-flashing-guide-by.html

      Delete
  38. V1.1 has been out for v3 tablets of the iv40. Any good reviews of this update?

    ReplyDelete
  39. Hello
    I have used a Huawei E122 UMTS Dongle on my Onda Vi40 after WLAN is not working anymore! Only after factory reset the WLAN ist working again. What can I do?

    ReplyDelete
  40. Colonel, SOS, pls help with 'error downloading messages' from the play. I have cleared cache of all google app services, restarted, yet not downloading. Thank you for your great work/resource here. God bless you.

    ReplyDelete
  41. Colonnello salve ho un gosso problema dopo aver effettuato l‘aggiornamento non riesco più a lavorare con la moa internet key E122 ..$non riesco piu ad entrare su impstazioni-reti mobili ..mi compare un messaggio di errore e si chiude il processo in modo anomalo....cosa fare???? Helpppppppp!!!

    ReplyDelete
  42. Hello Colonel, I have a serious problem, before I
    could upgrade to work with my internet key
    E122, now after the update I can no longer
    working on it with the E122. I'm sure because of
    the file because I RunMe.bat excluding
    telephone services ... How can I restore them??

    ReplyDelete
    Replies
    1. Hi :-)

      I'm sorry, I have no idea how to fix that. If the upgrade somehow doesn't support it anymore, all I can suggest is to downgrade to an earlier firmware version. Maybe somebody on Slatedroid.com can give you better advise?

      Good luck!

      Delete
  43. Hi.. I have Onda Vi40 v3 bought last month. Have touch screen issues. Some part of screens is not working. Have to rotate it (change direction) in order to type/tab something. hard to play games. Any solutions? already upgrade to firmware 1.0

    ReplyDelete
  44. Hi.. is there a new firmware 1.01 ?

    ReplyDelete
  45. I am stuck, I just bought the Onda Vi40, but it was supplied with no instructions at all. I am not a techy person and so I just plugged it into my PC and the PC downloaded 3 software files and now the unit does nothing else. Just a green man bobbing up and down. I have no clue what I'm expected to do to start using this thing. What a silly idea selling something without instruction for use, even to start the bloody thing.
    So can anyone tell me how or what I am supposed to do to get going, Plllleeeaaassee!!!!!!!!!!!

    ReplyDelete
  46. Hi how to know the harware version i have on my onda?

    Regards

    ReplyDelete
    Replies
    1. You should be able to find a "v1" or "v3" somewhere in the serial number on the back of the tablet.

      Delete
  47. Hi colonel can you please help me? I bought the onda vi40 elite and Iam very desapointed. The web surfing is very slow and it crash very often' i've tryed installing opera and dolphin and the last one run a litle better. The rear camera is unusable and youtube and facebook are not supported by the device. I've restore to default facttory settings and it goes even worse. The shell and apps run quite good. can you please give me a suggest. My settings sistem is:
    Onda vi40 elite v3
    Versione android 4.0.3
    Banda di base 1.1
    Versione kernel 3.0.8+ Igm@WServer #32
    Numero build mid-eng 4.0.3 IML74K 20120409 test-keys
    thank you.

    ReplyDelete
    Replies
    1. Hi,
      I just received my Vi40 elite with the exact same specs. I notice some lag too, at times, and regardless the browser.
      Another thing that surprises me is the inability to install any basic Google apps despite what they say on Onda-tablet about this update ("Android 4.0.3 V1.1 full support Google Play,Angry Bird,Youtube and so on....")
      So,rather than applying the market fix, I will first try to re-flash the tablet with the firmware. I could install some apps like youtube, gmail and maps through apk files, but impossible to have Talk working. Hopefully re-flashing will help. I'll report back once done.

      Delete
  48. Hi :-)

    It looks like you have the latest 1.1 firmware already on it. I could never test that one because I have the V1 hardware version and Onda never released that firmwareversion for my v1 tablet.

    I'm a little surprised you have these problem because so far a lot of people seem to be very happy with the 1.1 firmware.

    As for Youtube, try this version:

    http://chinamobiles.org/downloads/zap/ICSYouTube.zip

    ReplyDelete
  49. As promised, this is my feedback on re-flashing the 1.1 firmware:
    The "format update" operation went fine but didn't change anything to my problems with Google Play.
    I clarify that my problem is not with paid apps, I bought and installed a few already, but that most basic Google apps are reported as "incompatible", like youtube, maps and Google talk (!). For most, I just have to install them from a compatible apk file, but all the ones I tried for Gtalk would either "not install" or crash.

    does anybody have a working Google Talk apk for Vi40 ?? This is the most frustrating point for me. At the moment I use IM+ as an alternative.

    Little treat: as I don't like to come visiting with empty hands, I brought you this proper tablet version of Youtube (th eone with the 3D carousel) that works great on Vi40:
    Youtube.apk
    It comes from an archive called newtech25_for_ics4.0.3.zip found during my research for a working gtalk app.

    Cheers and thanks for your blog Colonel Zap!
    Bubbah@gadgetvictims.com

    ReplyDelete
  50. Thank you so much for the feedback and the Youtube app. I have this ICS problem on quite a few devices, including some phones, no idea how to convince the the play store to be revealing more apps :-(

    ReplyDelete
  51. http://mediafire.com/?o0ib1zpldqzhq8a

    App. for Google Voice or Google Talk for Android Tablet

    ReplyDelete
  52. Thanks, but that's quite different from Google Talk, which I eventually found as stock403Talk.zip from xda-developpers.com (topic "ICS - GTalk 4.0.3 - Fully Transparent")
    It must be installed through recovery. The text chat application itself works, but any attempt to start a voice or video session will crash the application.

    ReplyDelete
  53. Onda Vi40 16GB is stucked to "Android" logo in start-up. What can i do guys?

    ReplyDelete
  54. looks like you will have to re flash the firmware

    ReplyDelete
    Replies
    1. Do you know how can I!Livesuite can't connect the device.Thanks!

      Delete
    2. Hold down the "menu" button *while* plugging the usb cable. Right after that, *while still holding the menu button*, press the power button -several times quickly (can take ~10 times)- until Windows reports a USB device plugged. This part of the procedure sounds strange but is absolutely important. There is a full procedure "by Francis" on this blog, and another good one on the site Topnotchtablets.com

      Delete
  55. Hi,
    What is the V1 Version and the V3 Version? how can I know which one I have?
    and is there a way to calibrate the G-Sensor? because after I installed the latest version of the V3 v1.2rc2 the screen always in Portrait orientation and it's hard to make it Landscape, after I hold it straight and it's not comfortable.
    thanks for help!

    ReplyDelete
  56. Hi, when i installed the V1 1.0 firmware, my touchscreen inverted. So when i touch on the top right of screen, the tablet registers the touch on the bottom left of screen. And when i flip the tablet, the screen goes upside down, please help if you can.

    ReplyDelete
    Replies
    1. Hi :-) There are two different hardware versions of this tablet, V1 and V3, you probably flashed a firmware that´s not made for your hardware.

      Delete
  57. Hello i have just found out the full list of firmware updates including for the v1 hardware. The link is: http://onda.cn/Tablet/ProductInfo.aspx?ProductId=179. the page may need translating but if you use Google chrome it will translate what you need to know for you.

    ReplyDelete
  58. I need help!
    After updating the firmware of onda VI40 Elite, the language was in Chinese. I need to configure Portuguese. Can someone help me

    ReplyDelete
    Replies
    1. Go into the settings find an "A" symbol. next on the right, click on the first entry on top. Good luck :-)

      Delete
    2. Dear ColonelZap,
      I have tried all the methods in your blog, but I still can't flash my onda Vi40.
      Here is my onda version:

      android version 4.0.3
      baseband version 1.0
      kernel version 3.0.8+
      build number mid-eng 4.0.3 iml74k 20120308 test-keys

      SN VI40AC3V3B06201
      BUT IAM NOT SURE IF IT IS VERSION 1 OR 3???


      do you think it is version 3?

      I have download the new firmware update releaseed in July 2012 from onda website and also from this website/blog but neither of them work when I flash it.

      I also have press the M key button three times and even more than that but still no luck.
      What should I do?? because every time I reboot the tab it returns to Chinese language and the app i just installed gone.

      I DO NEED YOU HELP.
      Thank in advance

      Delete
    3. Hi :-)

      I'm sorry but I can't help you :-( I haven't had this tablet for a LONG time, I have no idea about the current model or firmwares.

      If I were you, I'd look for help on slatedroid.com.

      Sorry again but I am clueless :-(

      Delete
    4. Thanks anyway,

      and thanks for giving the slatedroid.com

      cheers

      Delete
  59. Hi Colonel, thanks for all the videos and tutorials, great stuff!!

    I just bought my Vi40 from China, have flashed it and installed the new firmware should I still use the market fix script.

    ReplyDelete
  60. Help, my tablet is only on the home screen.
    Have you tried putting the firmware with livesuit, but he does not recognize usb

    ReplyDelete